Jump to content


Oovee will not accept mods/code etc ripped from other games or made from models with illegal/unsuitable copyright or not in accordance with licenses and/or forum rules. Any Mods will be removed and the user may be banned.
Only statements relating to Spintires that are posted here by Oovee staff are official statements from Oovee limited and Spin Tires

There is a issue with the Facebook Login. Until this is fixed you can request a password reset using the email you use to access Facebook.

Photo
- - - - -

Logs stuck/frozen/unmovable from Logging Kiosks


Best Answer Localhost , 08 March 2017 - 08:22 AM

As usual, if you suspect ST+ might be the culprist, start by uninstalling it and see if it changes anything.

I doubt it's ST+ this time. most likely one of your mods/maps overwrote media/classes/models/log_[short, medium, or long]_a.xml, or maybe the log's model.

 

I know you said "it won't interact with physics" but just to be sure: if you try to grapple a log, does the grappler go through the log, or can you hold it but not move it no matter what?

(the latter happens when the mass of something is set to 0, in an xml file)

 

edit: fixed typos

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 oneupper

oneupper

    Turn Up

  • Experienced Member
  • PipPip
  • 10 posts

Posted 08 March 2017 - 06:11 AM

I've just recently come across an issue while playing.

 

When I spawn logs at a kiosk (doesn't matter which map) they are indefinitely stuck.  I cannot use a crane to lift them.  I can't even drive a truck into them in an attempt to make them move.

 

When the log spawns, it won't interact with physics.  It simply spawns in at the kiosk, and is frozen.

 

I'm using SpinTiresPlus v8hf4.

 

This problem occurs in hardcore and casual mode.  Changing the string value for  HardcoreAutoLogs="false" in SPT config doesn't help either.

 

Just wondering if anybody else has experienced this bug.

 

Thanks for any help I might get!

-Upper

Attached Files



#2 Localhost

Localhost

    Member

  • Community Contributor
  • PipPip
  • 286 posts

Posted 08 March 2017 - 08:22 AM   Best Answer

As usual, if you suspect ST+ might be the culprist, start by uninstalling it and see if it changes anything.

I doubt it's ST+ this time. most likely one of your mods/maps overwrote media/classes/models/log_[short, medium, or long]_a.xml, or maybe the log's model.

 

I know you said "it won't interact with physics" but just to be sure: if you try to grapple a log, does the grappler go through the log, or can you hold it but not move it no matter what?

(the latter happens when the mass of something is set to 0, in an xml file)

 

edit: fixed typos


Edited by Localhost, 09 March 2017 - 05:42 AM.


#3 Schlammspringer

Schlammspringer

    Advanced Member

  • Community Contributor
  • PipPipPip
  • 632 posts
  • LocationBavaria

Posted 08 March 2017 - 05:35 PM

Exactly. Some of your mod might have overwritten the original logs.

By deleting everything eccept "collision=dynamic" out of the "PhysicalModel-Body" part out ot the \classes .xml you change the behaviour of the logs to react as "static" objects.

Look at your media\classes\models for the files localhost mentioned before and delete them.

Then everything should be fine again :)


Edited by Schlammspringer, 08 March 2017 - 05:36 PM.


#4 oneupper

oneupper

    Turn Up

  • Experienced Member
  • PipPip
  • 10 posts

Posted 09 March 2017 - 05:15 AM

Thank you so much guys!

 

I just went into my zipped Media Folder, copied the 3 log model xmls and pasted them into my unzipped media/classes/models folder and that has fixed my problem.

 

It seems that the problem was a map mod that added it's own short log a xml into the media folder that made the logs stuck.

 

Again, thanks so much for the quick reply and nailing the issue immediately.

 

:D


Edited by oneupper, 09 March 2017 - 05:17 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users